Polly.RateLimiting
by: Michael Wolfenden, App vNext
- 1.173k total downloads
- Latest version: 8.8.0
Polly.RateLimiting is a .NET resilience and transient-fault-handling library that allows developers to express resilience strategies using a Rate Limiter in a fluent and thread-safe manner.
PolySharp
by: Sergio Pedri
- 675 total downloads
- Latest version: 1.16.0+99a4dcece8e10c8bedf0871ac4cdb8650f2b649a
PolySharp provides generated, source-only polyfills for C# language features, to easily use all runtime-agnostic features downlevel
PolyType
by: Eirik Tsarpalis
- 467 total downloads
- Latest version: 2.0.0-rc.2
Practical generic programming for C#
Pomelo.EntityFrameworkCore.MySql
by: Laurents Meyer, Caleb Lloyd, Yuko Zheng
- 1.089k total downloads
- Latest version: 9.0.0
Pomelo's MySQL database provider for Entity Framework Core.
Pomelo.JsonObject
by: Pomelo.JsonObject
- 135 total downloads
- Latest version: 2.2.1
MySQL provider for Entity Framework Core
Portable.BouncyCastle
by: Claire Novotny
- 670 total downloads
- Latest version: 1.9.0
BouncyCastle portable version with support for .NET 4, .NET Standard 2.0
Portable.BouncyCastle-Signed
by: Mark Junker
- 86 total downloads
- Latest version: 1.7.0.2
BouncyCastle.Crypto is a cryptography API providing:
-Generation and parsing of PKCS#12 files.
-X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
-PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
-Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
-Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC.
-Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
-Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte.
-Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA.
-Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1.
-Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool.
-Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA.
-Key Agreement: Diffie-Hellman and EC-DH.
-Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3.
-PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2.
-OpenPGP (RFC 2440)
-Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
-Online Certificate Status Protocol (OCSP, RFC 2560).
-Time Stamp Protocol (TSP, RFC 3161).
-TLS/SSL Client with support for client side authentication.
Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, Silverlight 5, MonoTouch, MonoAndroid
Portable.ConcurrentDictionary
by: Stef Heyenrath
- 104 total downloads
- Latest version: 1.0.4
This is a .NET Standard 1.0, .NET 2.0, .NET 3.5, Silverlight 5.0 and Windows Phone Silverlight 8.0 & 8.1 backport from System.Collections.Concurrent.ConcurrentDictionary as defined in .NET Core
Postgres.psql
by: ChernenkoAV
- 19 total downloads
- Latest version: 16.11.0
The package contains the PostgreSql 16.11 win-x64 client part in the form of psql, pg_dump, pg_dumpall, pg_restore. Applies to inline script tasks when building msbuild and etc.
Pragmastat
by: Andrey Akinshin
- 4.408k total downloads
- Latest version: 14.0.1
Pragmatic Statistical Toolkit
prometheus-net
by: andrasm, qed-, lakario, sandersaares
- 5.811k total downloads
- Latest version: 8.2.1
.NET client library for the Prometheus monitoring and alerting system
prometheus-net.AspNetCore
by: andrasm, qed-, lakario, sandersaares
- 1.6k total downloads
- Latest version: 8.2.1
ASP.NET Core middleware and stand-alone Kestrel server for exporting metrics to Prometheus
prometheus-net.SystemMetrics
by: Daniel Lo Nigro
- 139 total downloads
- Latest version: 3.1.0
Export system metrics (CPU usage, disk usage, etc) to Prometheus from your .NET app.
protobuf-net
by: Marc Gravell
- 3.145k total downloads
- Latest version: 3.4.30
Provides simple access to fast and efficient "Protocol Buffers" serialization from .NET applications
protobuf-net.Core
by: Marc Gravell
- 2.161k total downloads
- Latest version: 3.4.30
The protobuf-net serialization engine and build-time tooling; most projects should reference protobuf-net, which adds the runtime type model
protobuf-net.Grpc
by: Marc Gravell
- 3.093k total downloads
- Latest version: 1.3.14
Code-first gRPC for .NET: declare services as .NET interfaces, with no .proto file and no generated client; shared core for clients and servers
protobuf-net.Grpc.AspNetCore
by: Marc Gravell
- 1.14k total downloads
- Latest version: 1.3.14
Hosts code-first gRPC services in ASP.NET Core
protobuf-net.Grpc.AspNetCore.Reflection
by: Marc Gravell
- 793 total downloads
- Latest version: 1.3.14
gRPC server reflection for code-first services hosted in ASP.NET Core
protobuf-net.Grpc.Reflection
by: Marc Gravell
- 819 total downloads
- Latest version: 1.3.14
Generates .proto schemas from code-first gRPC contracts, and implements the gRPC reflection service
protobuf-net.Reflection
by: Marc Gravell
- 1.427k total downloads
- Latest version: 3.4.30
ProtoBuf DSL (proto2 / proto3) and descriptor tools for protobuf-net